Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8828 closed bug (fixed)

Button: Refresh does not re-enable disabled button.

Reported by: ezyang Owned by: tj.vantoll
Priority: minor Milestone: 1.9.2
Component: ui.button Version: 1.9.1
Keywords: regression haspatch Cc:
Blocked by: Blocking:

Description

See example: http://jsfiddle.net/U2Gmm/2/

It does, however, manage to capture enabled to disabled transition.

Change History (13)

comment:1 Changed 7 years ago by Scott González

Component: ui.coreui.button
Status: newopen
Summary: Refresh does not re-enabled disabled button.Button: Refresh does not re-enabled disabled button.

comment:2 Changed 7 years ago by Scott González

Summary: Button: Refresh does not re-enabled disabled button.Button: Refresh does not re-enable disabled button.

comment:3 Changed 7 years ago by tj.vantoll

Resolution: notabug
Status: openclosed

@ezyang The example you provided has a JS error because there is no refresh on $.fn. In order to call button's refresh method you must use $('button').button('refresh'), which works fine - http://jsfiddle.net/tj_vantoll/hWkvs/.

If you have an example that shows this issue without a JS error please comment and we can reinvestigate.

comment:4 Changed 7 years ago by ezyang

Oops, sorry about the typo! It seems that the older version of jQuery UI handles it properly, but not the latest: http://jsfiddle.net/U2Gmm/3/

comment:5 Changed 7 years ago by Scott González

Keywords: regression added
Resolution: notabug
Status: closedreopened

Interestingly, this is a regression in 1.9.1

comment:6 Changed 7 years ago by Scott González

Status: reopenedopen

comment:7 Changed 7 years ago by tj.vantoll

Owner: set to tj.vantoll
Status: openassigned

Since this is a 1.9.1 regression this was likely caused by my change here - https://github.com/jquery/jquery-ui/commit/5e24a1ce4b337830b37511305a6ddefe797fd40c. I'll look into this.

comment:8 Changed 7 years ago by mikesherov

So, just as a point of strategy, I'd like to see this NOT rolled back, but adding even more tests to keep both fixes, if possible.

comment:9 Changed 7 years ago by tj.vantoll

@mikesherov Agreed. I'm on it.

comment:10 Changed 7 years ago by tj.vantoll

Keywords: haspatch added

comment:11 Changed 7 years ago by TJ VanToll

Resolution: fixed
Status: assignedclosed

Button: Fixing handling of the disabled options on refresh method calls. Fixed #8828 - Button: Refresh does not re-enable disabled button.

Changeset: 93abe02b6052143fac30393291da3fc254bde996

comment:12 Changed 7 years ago by TJ VanToll

Button: Fixing handling of the disabled options on refresh method calls. Fixed #8828 - Button: Refresh does not re-enable disabled button. (cherry picked from commit 93abe02b6052143fac30393291da3fc254bde996)

Changeset: 8def77cb5cfefb733874d15a2294f02fc5ae78ae

comment:13 Changed 7 years ago by Jörn Zaefferer

Milestone: 1.10.01.9.2

Merged into 1-9-stable.

Note: See TracTickets for help on using tickets.