Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8892 closed bug (fixed)

Slider: Multiple Sliders have Conflict with options.values

Reported by: dbarnes Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.slider Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

Bit of an edge-case here, but a problem nonetheless. (I'll be submitting a PR via Github once I finish creating this ticket here)

Basically, if you initialize multiple range sliders at once, and you pass an array as the values option, the array that you use ends up being shared between all of the sliders that were initialized in that command. (because of it's object reference) When you move the handles of one slider, and move on to another, the handles jump around because of the conflict in options.values.

JSFiddle created with reproduction steps, Github PR incoming

Change History (4)

comment:1 Changed 7 years ago by tj.vantoll

Milestone: 1.10.01.11.0
Status: newopen
Summary: Multiple Sliders have Conflict with options.valuesSlider: Multiple Sliders have Conflict with options.values

comment:3 Changed 7 years ago by Dominic Barnes

Resolution: fixed
Status: openclosed

Slider: Create clone of options.values during _create(). Fixed #8892 - Multiple Sliders have Conflict with options.values.

Changeset: 209443d716587d896ffcdf26c0fd8c8a23437b3c

comment:4 Changed 7 years ago by Scott González

Milestone: 1.11.01.10.0
Note: See TracTickets for help on using tickets.