Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8896 closed bug (duplicate)

Tabs Issue When URL Contains Un-escaped Spaces

Reported by: heironimus Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.tabs Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

Affects: jQuery UI 1.9.2 (Versions 1.9.1 and before do not have this issue)

Browsers Affected: IE 8 (Windows XP SP3) and 9 (Windows 7 SP1) This is not a problem with Chrome or Firefox.

How to reproduce issue: Browse to a page containing a jQuery UI Tabs Widget using a URL that has more than one query string parameter. The first query string parameter should contain one or more un-escaped spaces (i.e. " " vs. "%20") [e.g. http://localhost/jQuery_UI_Tabs_Issue/1.9.2-tabs_issue.htm?arg1=one two three&arg2=four]. The jQuery UI Tabs Widget will show all tabs, regardless of the tab that is selected. Remove the un-escaped spaces from the URL will correct the issue [e.g. http://localhost/jQuery_UI_Tabs_Issue/1.9.2-tabs_issue.htm?arg1=one%20two%20three&arg2=four].

Change History (3)

comment:1 Changed 7 years ago by heironimus

Removing the code change made in Fix #8777 seems to resolve the issue.

comment:2 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8877.
Hi heironimus, thanks for taking the time to contribute to the jQuery UI project. I was able to recreate your problem but it looks like it was fixed by this commit in master which is due in 1.10. Therefore, I'm going to close this as a duplicate of #8877.

If you find this is still an issue let us know and we can reinvestigate. You can use http://code.jquery.com/ui/jquery-ui-git.css and http://code.jquery.com/ui/jquery-ui-git.js to test against the latest code in the master branch.

Thanks.

comment:3 Changed 7 years ago by tj.vantoll

#8957 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.