Opened 7 years ago

Closed 7 years ago

#8914 closed bug (fixed)

Effects: odd behaviour of css hook when setting backgroundColor to transparent in IE7/8

Reported by: uibugger123 Owned by: mikesherov
Priority: minor Milestone: 1.10.0
Component: ui.effects.core Version: 1.9.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

jQuery 1.8.3 jQuery UI 1.9.2 in the resource tab.

http://jsfiddle.net/jhDH2/3/

With jQuery alone, everything works fine. However jQuery UI 1.9.2 css hook seems to force lookup color of parent element and set it as background color instead of transparent.

In IE9, the color is set to rgba(0, 0, 0, 0) but in IE8/7 the color is set to rgb(255,0,0).

Also I was trying to post a bug report but trac seems to keep giving me OperationalError: (2006, 'MySQL server has gone away') error...

Change History (6)

comment:1 Changed 7 years ago by tj.vantoll

Owner: set to uibugger123
Status: newpending

Hi uibugger123, thanks for taking the time to contribute to the jQuery UI project.

This is intended behavior, see https://github.com/jquery/jquery-ui/blob/master/ui/jquery.ui.effect.js#L603. Are you seeing any differences in the behavior in your example? For me it looks to work the same in IE7 and IE8 as it does in the latest Chrome.

Here's a minified test case and again it looks the same in IE 7 / 8 as it does in Chrome - http://jsfiddle.net/tj_vantoll/cGVBX/3/.

Thanks.

comment:2 Changed 7 years ago by uibugger123

Status: pendingnew

http://jsfiddle.net/cGVBX/4/ I've updated your example, setting background color to parent background color is definitely a bug.

comment:3 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: odd behaviour of css hook in jQuery UI 1.9.2 when setting backgroundColor to transparent in IE7/8Effects: odd behaviour of css hook when setting backgroundColor to transparent in IE7/8
Version: 1.9.21.9.0

I see the issue now - http://jsfiddle.net/tj_vantoll/aqnfz/. I also confirmed that this issue is not present in jQuery UI 1.8.24 and does not occur if jQuery UI is not used.

comment:4 Changed 7 years ago by Scott González

Component: ui.coreui.effects.core
Keywords: regression added

This is because jQuery Color 2.0 adds cssHooks for everything and special cases transparent. The special casing needs to exist only in animations. We should probably file an issue in the jquery-color repo, but I want to discuss the problem with gnarf before filing the issue.

comment:5 Changed 7 years ago by Scott González

Owner: changed from uibugger123 to mikesherov
Status: openassigned

comment:6 Changed 7 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Effects: Avoid cssHook blending in non-rgba browsers when the value is "transparent". Fixes #8914: odd behaviour of css hook when setting backgroundColor to transparent in IE7/8

Changeset: da01fb6a346e1ece3fd6dde5556a98f099e0c0e0

Note: See TracTickets for help on using tickets.