Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8920 closed bug (fixed)

Tooltip potential setinterval endless loop

Reported by: KopiasCsaba Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.tooltip Version: 1.9.2
Keywords: Cc:
Blocked by: Blocking:

Description

Hello!

I'm working on a bigger project, with hundreds of draggables, droppables, and many of them has tooltip too.

In this kind of situations, sometimes i've noticed, that an endless loop going on because of the tooltip. (Casues 100% cpu eating).

The problem is here:

	// Handle tracking tooltips that are shown with a delay (#8644). As soon
		// as the tooltip is visible, position the tooltip using the most recent
		// event.
		if ( this.options.show && this.options.show.delay ) {
			delayedShow = setInterval(function() {
				if ( tooltip.is( ":visible" ) ) {
					position( positionOption.of );
					clearInterval( delayedShow );
				}
			}, $.fx.interval );
		}

If the tooltip is not visible, when the interval executes, then it will never clears itself.

Possible solution is to put that outside of that if, but i'm not sure of the whole inner structure of the tooltip.

Change History (2)

comment:1 Changed 7 years ago by Scott González

Resolution: fixed
Status: newclosed

Tooltip: Clear the tracking interval on close. Fixes #8920 -Tooltip potential setinterval endless loop.

Changeset: 9cbd4b42221389277cf90a6662f17c500d1a77df

comment:2 Changed 7 years ago by KopiasCsaba

Thank you very much!

Note: See TracTickets for help on using tickets.