Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#8984 closed bug (fixed)

Dialog: Modal dialogs display behind overlay when using appendTo option

Reported by: limitstudios Owned by:
Priority: major Milestone: 1.10.1
Component: ui.dialog Version: 1.10.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

Using the code provided at jsfiddle or url below and clicking the button causes the overlay to position above the dialog, making the dialog unusable.

http://jsfiddle.net/rFAkt/

http://www.limit-studios.com/jquery/jquery-dialog.php

Change History (14)

comment:1 Changed 7 years ago by limitstudios

The reason it is attached to a form is the dialog contains form fields which are then submitted via the dialog

comment:2 Changed 7 years ago by Scott González

Keywords: regression added
Milestone: none1.10.1
Priority: minormajor
Status: newopen
Summary: jQueryUI 1.10 Overlay is above dialogDialog: Modal dialogs display behind overlay when using appendTo option

A properly reduced test case: http://jsfiddle.net/rFAkt/2/

comment:3 Changed 7 years ago by Jörn Zaefferer

Gonna look into this, along with the open dialog PR.

comment:4 Changed 7 years ago by mikesherov

Owner: set to joern.zaefferer
Status: openassigned

comment:5 Changed 7 years ago by Jörn Zaefferer

Owner: joern.zaefferer deleted
Status: assignedopen

Since David is working on other dialog bugs and I'm not going to tackle this in the next few days, unassigning myself...

comment:6 Changed 7 years ago by C6AC165B-7B1E-445F-804B-A1BFED06162F

"Modal dialogs display behind overlay when using appendTo option"

And overlays do not display at all when used in a fully scoped css theme. I have to use hacks to work around this and the issue of the ticket. Such as:

var dz = $(".ui-front").css( "z-index" )
$(".ui-widget-overlay").css({ "z-index": dz-1 });
$(".ui-widget-overlay").appendTo("#my-scoping-id");

I have a long list of bugs that occur when using scoped css themes. Will post in time. I only just now managed to register here, I tried all kinds of random strings as a username last night (there is no way someone has already registered as "vdfuh5ngsby7atbva3dhpoltdysb", yet I was told that name was already in use...), then it occurred to me to register as a GUID, that worked. So here I am, and once I can be bothered to compile and document the long list of bugs that I have observed, I will post them.

Last edited 7 years ago by C6AC165B-7B1E-445F-804B-A1BFED06162F (previous) (diff)

comment:7 Changed 7 years ago by djQuery

Submitted pull request https://github.com/jquery/jquery-ui/pull/894

Let me know if there is any more work that needs to be done on this.

comment:8 Changed 7 years ago by David Sullivan

Resolution: fixed
Status: openclosed

Dialog: modified _createOverlay to _appendTo instead of document.body. Fixed #8984 - Modal dialogs display behind overlay when using appendTo option

Changeset: 55360eeb7eae5c560d51b09178e64d83c59223a6

comment:9 Changed 7 years ago by limitstudios

I added the commited code to my jqueryui file and it still didn't fix my test case

comment:10 Changed 7 years ago by Scott González

@limitstudios We'd need a reduced test case showing the problem.

comment:11 Changed 7 years ago by limitstudios

yep I'm trying to create a reduce one, but only since upgraded to 1.10.0 has caused this

comment:12 Changed 7 years ago by MosheElisha

The fix in 1.10.1 works for me. Thanks!

comment:13 Changed 7 years ago by TUX

Comenten esta linea de codigo del Jquery y con eso se soluciona:

$(".ui-dialog:visible:last .ui-dialog-content")

.data("ui-dialog")._focusTabbable();

Saludos desde Merida, Yucatan, Mexico...

comment:14 Changed 7 years ago by Scott González

@TUX Please stop posting that comment in various closed tickets.

Note: See TracTickets for help on using tickets.