Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9039 closed feature (duplicate)

right to left and i18n and globalization support

Reported by: sweb Owned by: sweb
Priority: minor Milestone: none
Component: ui.datepicker Version: 1.10.0
Keywords: Cc:
Blocked by: Blocking:

Description

Why jquery unitl version 1.10 dosnet think about i18n and right to left supported. We need non-georgian calendar such as persian and arabic calendar for using i18n based web application.

take a look on dojo. it's i18n based from long time ago but you dont.

http://dojotoolkit.org/reference-guide/1.8/dijit/Calendar.html http://dojotoolkit.org/reference-guide/1.8/dojox/date/hebrew.html

we need fully i18n based ui. right to left supported and fully global.

Change History (8)

comment:1 Changed 7 years ago by Scott González

Component: ui.coreui.datepicker
Owner: set to sweb
Status: newpending

Are you asking about RTL or are you really asking about non-Gregorian calendars? The two are very different.

comment:2 in reply to:  1 Changed 7 years ago by sweb

Status: pendingnew

Replying to scott.gonzalez:

Are you asking about RTL or are you really asking about non-Gregorian calendars? The two are very different.

Both of them for best i18n support. Rtl need think about direction about all ui element. For non georgian calendars we can use predefined algorithm on icu project. http://site.icu-project.org/charts/comparison. persian and arabic (islamic-civil) can be very useful.

C sources for calendar support. with this algorithms we have all 12 most important world calendars. http://www.icu-project.org/apiref/icu4c/calendar_8h_source.html

Last edited 7 years ago by sweb (previous) (diff)

comment:3 Changed 7 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5789.

comment:4 in reply to:  3 Changed 7 years ago by sweb

Replying to scott.gonzalez:

Duplicate of #5789.

There is no just persian calendar check icu calendars.

comment:5 Changed 7 years ago by Scott González

I'm well aware, did you read the title and description which are generic?

comment:6 in reply to:  5 Changed 7 years ago by sweb

Replying to scott.gonzalez:

I'm well aware, did you read the title and description which are generic?

Persian calendar need right to left. globalize need all feature like right to left, non georgian calendar, measure units, currency unit and etc. I want to warn you about these useful features. so you need to think on base to design jquery ui via globalization not just for right to left, calendar support. think global for each unit of jquery ui. I think it's require to change many structures but can help to growing usage of jquery ui in special locales.

We have cldr project to get all locale data, why jquery ui dosnt use them ? http://unicode.org/cldr/trac/browser/trunk/common/main/en.xml http://unicode.org/cldr/trac/browser/trunk/common/main/fa.xml http://unicode.org/cldr/trac/browser/trunk/common/main/ar.xml http://unicode.org/cldr/trac/browser/trunk/common/main/de.xml

also icu project have many useful algorithms. i think it's can be a big feature on jquery ui.

dont duplicate my new feature.

comment:7 Changed 7 years ago by Scott González

I think there's some misunderstanding going on here.

Datepicker already supports RTL, and many of the i18n files that we provide require that support. #5789 is about supporting other calendar systems. Ignore the fact that the person who filed the ticket was asking specifically about Persian calendars.

All of the things you mention are already on our roadmap. We plan on using CLDR as the data source for Globalize, which will be what powers the datepicker rewrite. We'd gladly accept your help if you're interested in working on this.

comment:8 Changed 7 years ago by sweb

Note: See TracTickets for help on using tickets.