Opened 7 years ago

Closed 7 years ago

#9127 closed bug (duplicate)

Draggable with constraint not considering dragged element's zoom

Reported by: rjperes Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.10.1
Keywords: Cc:
Blocked by: Blocking:

Description

When dragging an element with zoom inside a container to which it is constrained, the behavior is not considering the zoom for evaluating if the element is going outside the bounds of its container. For example, if an element has 50% zoom, its dragging is stopped before it actually reaches the border of the container, because the draggable behavior is considering the declared width of the element instead of the actual width (declared width * zoom). Important to keep in mind that there are two ways to apply a zoom to an element: one is through the zoom CSS property, the other is through the transform CSS property, by using scale(0.5), for example.

Change History (1)

comment:1 Changed 7 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #8452.
Hi rjperes,

Thanks for taking the time to contribute to the jQuery UI project. Neither of these use cases are supported by jQuery or jQuery UI, see #8452 & http://contribute.jquery.org/wont-fix/.

Note: See TracTickets for help on using tickets.