Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#8452 closed bug (wontfix)

Draggable objects jump around when dragging at zoom levels other than 100% in Chrome

Reported by: masak Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.draggable Version: 1.8.21
Keywords: Cc:
Blocked by: Blocking:

Description

On http://jqueryui.com/demos/draggable/ using Google Chrome Version 19.0.1084.56 (on Ubuntu), dragging works fine with zoom level 100%. With other zoom levels, the initial coordinates of the box are wrongly computed, making the box jerk when dragged. The effect gets more pronounced the further the box is from its point of origin.

Here's how you change zoom levels on Chrome: Ctrl++ and Ctrl+-, or the wrench menu and "Zoom".

My expectation is for dragging to work fine even under other zoom levels than 100%.

Change History (9)

comment:1 Changed 7 years ago by mrjeff

I am experiencing the exact same issue using Chrome Version 20.0.1132.57 on Windows. Issue appears for me when revert is set to 'invalid' and item is dragged on top of item which is valid.

Everything appears to be working working fine on IE9 and Firefox 14.

comment:2 Changed 7 years ago by ahmiz

Came across this while searching for "Chrome zoom" bugs.

Perhaps this is related to the Slide effect bug I opened at http://bugs.jqueryui.com/ticket/8538

That also only affects Chrome when the page is zoomed in/out.

As for this issue, the effect can be clearly seen on the Draggable demos page at http://jqueryui.com/demos/draggable/, under "Revert position". Zoom in/out in Chrome, drag the "Revert to original" box, and watch the box suddenly jump to a different initial position before going back to its original position.

Last edited 7 years ago by ahmiz (previous) (diff)

comment:3 Changed 7 years ago by Scott González

Resolution: wontfix
Status: newclosed

jQuery doesn't support zooming.

comment:4 in reply to:  3 Changed 7 years ago by nick4fake

Replying to scott.gonzalez:

jQuery doesn't support zooming.

I think, you misunderstood the bug. It really exists. And it is related to jQuery ui, not jquery itself. Please, reopen it, it is annoying.

comment:5 Changed 7 years ago by Scott González

What did I misunderstand? Is this about a problem that only exists when the page is zoomed or not?

comment:6 in reply to:  5 Changed 7 years ago by masak

Replying to scott.gonzalez:

What did I misunderstand? Is this about a problem that only exists when the page is zoomed or not?

Yes, that is correct. Dragging doesn't work as expected on zoom levels other than 100%. The result is fragility in the face of zooming.

comment:7 Changed 7 years ago by Scott González

So what did I misunderstand? jQuery core doesn't handle zoomed pages.

comment:8 Changed 7 years ago by tj.vantoll

#9127 is a duplicate of this ticket.

comment:9 Changed 6 years ago by tj.vantoll

#9238 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.