Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#9189 closed bug (fixed)

Accordion: refresh() method incorrectly opens collapsed accordion

Reported by: mls81 Owned by:
Priority: minor Milestone: 1.10.3
Component: ui.accordion Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

When an accordion in jQuery UI 1.10.2 is in a fully collapsed state (i.e. no panels are open, 'collapsible' is true and 'active' is false), calling 'refresh' on the accordion will fire the 'activate' event on the first panel in the accordion even though the panel was not clicked or selected, causing that panel to open.

A demo of the bug is at http://jsfiddle.net/3dsxK/

The reason is a missing 'else' in jquery.ui.accordion.js on line 226.

This is wrong: } if ( options.active === false ) {

This is right: } else if ( options.active === false ) {

Change History (5)

comment:1 Changed 5 years ago by Scott González

Milestone: none1.11.0
Status: newopen
Summary: Accordion fires 'activate' event on the first panel of a collapsed accordion whenever the 'refresh' method is called.Accordion: refresh() method incorrectly opens collapsed accordion

comment:2 Changed 5 years ago by Scott González

Resolution: fixed
Status: openclosed

Accordion: Maintain collapsed state on refresh. Fixes #9189 - Accordion: refresh() method incorrectly opens collapsed accordion.

Changeset: 5a8596cdf3baa4d835e588cda9060a0537236c71

comment:3 Changed 5 years ago by Scott Gonz��lez

Accordion: Maintain collapsed state on refresh. Fixes #9189 - Accordion: refresh() method incorrectly opens collapsed accordion. (cherry picked from commit 5a8596cdf3baa4d835e588cda9060a0537236c71)

Changeset: a93ad182c837ef6c46323092a5538355e7ee3a7c

comment:4 Changed 5 years ago by Scott González

Milestone: 1.11.01.10.3

comment:5 Changed 4 years ago by tj.vantoll

#9268 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.