Opened 7 years ago

Closed 7 years ago

#9194 closed bug (duplicate)

selectable disabled issues

Reported by: penguin_brian Owned by:
Priority: minor Milestone: none
Component: ui.core Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

$( ".selector" ).selectable({ disabled: true });

Doesn't add "ui-sortable-disabled" to the class, but

$(".ui-selectable").selectable( "disable" )

Does. This is kind of inconsistent and confusing.

Having said that, I wish it wouldn't; I want to disable the control so that the user can interact with controls underneath (not sure if this is the best way yet), and the CSS style for ui-sortable-disabled sets some parameters that are inappropriate.

Change History (3)

comment:1 Changed 7 years ago by penguin_brian

Sorry, this should be against ui.selectable. Looks like I can't change it now :-(

comment:2 Changed 7 years ago by penguin_brian

Then again, this might be a core issue. _setOption() which is called by $(".ui-selectable").selectable( "disable" ) is provided by $.Widget

_setOption() does not appear to be called by options set in the constructor, so it won't add the class.

comment:3 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #5973.
This is a duplicate of #5973, sort of, which was fixed by https://github.com/jquery/jquery-ui/commit/44d07173db32b498e5f83f60db290ff1463daee3

Note: See TracTickets for help on using tickets.