Opened 4 years ago

Closed 2 years ago

Last modified 2 years ago

#9201 closed bug (fixed)

Autocomplete: Menu doesn't hide in IE 8

Reported by: aliedtke Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.autocomplete Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

In Internet Explorer 8 the menu of the autocomplete control doesn't hide on "lost focus":

  1. right click on a menuitem -> the contextmenu of the browser appears
  2. left click on another control or on a blank place of the page -> the menu doesn't hide.

The same behaviour occurs if you left click and select the text of the menuitems (event: selectstart).

I can't reproduce this bug in Firefox or Safari.

I developed a workaround for this problem but I can't exclude any crosseffects.

Change History (4)

comment:1 Changed 4 years ago by Scott González

Status: newopen
Summary: Autocomplete: menu doesn't hide in IE8Autocomplete: Menu doesn't hide in IE <10

comment:2 Changed 2 years ago by Scott González

Summary: Autocomplete: Menu doesn't hide in IE <10Autocomplete: Menu doesn't hide in IE 8

I'm guessing that since I changed the title of this ticket before that either 1) IE9 had the bug but was eventually patched or 2) I just didn't test very well; I cannot reproduce in IE9 today.

PR: https://github.com/jquery/jquery-ui/pull/1470

comment:3 Changed 2 years ago by Scott González

Resolution: fixed
Status: openclosed

Autocomplete: Restore focus after clicking a menu item, if necessary

Fixes #9201 Closes gh-1470

Changeset: 581bfb55bf4f4f614a6e0c0ac545cf1aa7d29d0a

comment:4 Changed 2 years ago by Scott González

Milestone: none1.12.0
Note: See TracTickets for help on using tickets.