Opened 6 years ago

Closed 6 years ago

#9233 closed bug (duplicate)

Bug #4239 (destroy draggable on drop) is not fixed.

Reported by: usiw Owned by: usiw
Priority: minor Milestone: none
Component: ui.draggable Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

Trying to destroy the draggable being dropped in the drop event of a droppable throws an error when the draggable calls stop on itself.

The original bug for this is mraked as "Fixed" but it still occurs in 1.10.2

Change History (4)

comment:1 Changed 6 years ago by mikesherov

This is a dupe of something I just fixed for 1.11. I'll find it shortly.

comment:2 Changed 6 years ago by mikesherov

Owner: set to usiw
Status: newpending

Thanks for contributin, usiw! I believe this is a duplicate of http://bugs.jqueryui.com/ticket/6889 Could you please provide a test case using the git version of jQuery UI in jsFiddle or JSBin showing the problem still exists?

comment:3 Changed 6 years ago by usiw

Status: pendingnew

I just built the latest from Github it has resolved this issue. The fix in #6889 also fixed the issue of the draggable cursor being applied inline to the BODY element when it's destroyed in the drop event handler.

This can be closed. Thanks!

comment:4 Changed 6 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #6889.

Note: See TracTickets for help on using tickets.