Opened 7 years ago

Closed 4 years ago

Last modified 3 years ago

#6889 closed bug (fixed)

Draggable: Cursor doesn't revert to pre-dragging state after revert action when original element is removed

Reported by: cburgdorf Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.draggable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

I fixed this bug for 1.8.9 http://bugs.jqueryui.com/ticket/6871

However, now that I had an even closer look on it I recognized that the cursor won't switch back to its pre-dragging state after the revert action has finished.

I made a jsFiddle that shows the bug:

http://jsfiddle.net/cburgdorf/XsrJf/

I also figured out that there is a cursor plugin for the draggable which should actually handle it. However it seems to fail in this special situation:

https://github.com/cburgdorf/jquery-ui/blob/master/ui/jquery.ui.draggable.js#L612

Change History (7)

comment:1 Changed 7 years ago by cburgdorf

I couldn't figure out how to edit my ticket. So, here is a updated version of the jsFiddle: http://jsfiddle.net/cburgdorf/XsrJf/4/

comment:2 Changed 5 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 5 years ago by mikesherov

Status: newopen
Summary: Cursor won't switch back to pre-dragging state after revert actionDraggable: Cursor doesn't revert to pre-dragging state after revert action when original element is removed

This and the original bug are now present again in 1.9: http://jsfiddle.net/EcwyG/

comment:4 Changed 4 years ago by Mike Sherov

Resolution: fixed
Status: openclosed

Draggable: allow draggable to defer destroying itself upon DOM removal until after stop is fired. Fixes #6889 - Draggable: Cursor doesn't revert to pre-dragging state after revert action when original element is removed.

Changeset: d345a0d7db841a143dcfdd3fb6fa6141cda435e9

comment:5 Changed 4 years ago by mikesherov

Milestone: 2.0.01.11.0

comment:6 Changed 4 years ago by mikesherov

#9233 is a duplicate of this ticket.

comment:7 Changed 3 years ago by mikesherov

#8980 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.