Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9263 closed bug (duplicate)

Autocomplete combobox Show All does not work

Reported by: mcapp32 Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.2
Keywords: Cc:
Blocked by: Blocking:

Description

I realize that there is a ticket that says this is fixed, however, the example on your site does not work, and my local project also will not work. If there is a fix, shouldn't this work on you site as well. If there is a link change for the javascript can I get that currently the example uses:

<link rel="stylesheet" href="http://code.jquery.com/ui/1.10.2/themes/smoothness/jquery-ui.css" /> <script src="http://code.jquery.com/jquery-1.9.1.js"></script> <script src="http://code.jquery.com/ui/1.10.2/jquery-ui.js"></script>

The error happens on : wasOpen = input.autocomplete( "widget" ).is( ":visible" );

if you rem that out then it happens on the line input.focus();

I suspect that if there is a fix it's an update for the links to the jquery.. I tried getting the latest code and droping it into my project but I got the exact same error when i pointed at the latest javascript.

Thank you for your help.

Change History (5)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9157.

comment:2 Changed 6 years ago by Scott González

We don't do a release after every bug fix. You need to wait for the 1.10.3 release...

comment:3 Changed 6 years ago by mcapp32

When is release 1.10.3 going to be available.. as time is of the essence.

comment:4 in reply to:  3 Changed 6 years ago by rephistorch

Replying to mcapp32:

When is release 1.10.3 going to be available.. as time is of the essence.

I hope this can help anyone else who is having this issue. I went ahead and looked at the source code to fix the issue. In the offending parts of code replace "input" with the following: $(this).siblings("input") That will solve the problem.

comment:5 Changed 6 years ago by sandeeproop

Another solution for this bug is to add. var self = this; in _createShowAllButton function and replace "input" with "self.this"

Note: See TracTickets for help on using tickets.