Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9307 closed bug (fixed)

Resizable: Erratic behavior of contained elements within scrollable grandparents

Reported by: christian314159 Owned by:
Priority: minor Milestone: 1.10.4
Component: ui.resizable Version: 1.10.3
Keywords: haspatch Cc:
Blocked by: Blocking:

Description

When you have resizables within a scrolling container to which they are contained to, they can't be properly resized to that elements' width.

Scenario 1: Resizable is 100% of the parent to start with; scroll to the far right and try to resize. Element will instantly resize to a much smaller width and will not be visible anymore until you scroll to the left again.

Scenario 2: Try to increase the width of a small element step by step by scrolling and resizing. You will eventually hit a limit although the boundaries of the parent have not been reached.

JsFiddle: http://jsfiddle.net/9XqG5/3/

Change History (6)

comment:1 Changed 5 years ago by mikesherov

Keywords: haspatch added

i haven't confirmed yet, but this has a patch: https://github.com/jquery/jquery-ui/pull/989/files

comment:2 Changed 5 years ago by tj.vantoll

Status: newopen
Summary: Resizable within scrolling container jump/can't be resized to containing elements' widthResizable: Erratic behavior of contained elements within scrollable grandparents

This is a tricky one to reduce as it seems to require 3 nodes. This is the best I could do: http://jsfiddle.net/tj_vantoll/ex8Zb/

The problem seems to be specifically related to having a node that has a width that is larger than its container, which would make sense given the pull request. But it's not quite that simple as it seems to require a scrollable grandparent. The issue only occurs when containment: "parent" is set.

comment:3 Changed 5 years ago by Christian Klammer

Resolution: fixed
Status: openclosed

Resizable: Fixed sign error on offset calculation. Fixes #9307 - Resizable: Erratic behavior of contained elements within scrollable grandparents

Changeset: 6df5c1a4ae738e591694e0fe2fa3bbb8b05f6b0a

comment:4 Changed 5 years ago by mikesherov

Milestone: none1.11.0

comment:5 Changed 5 years ago by Christian Klammer

Resizable: Fixed sign error on offset calculation. Fixes #9307 - Resizable: Erratic behavior of contained elements within scrollable grandparents (cherry picked from commit 6df5c1a4ae738e591694e0fe2fa3bbb8b05f6b0a)

Changeset: 1660c761e7fe3e790ec4dcb3a356a78ac2a1c7ed

comment:6 Changed 5 years ago by Scott González

Milestone: 1.11.01.10.4
Note: See TracTickets for help on using tickets.