Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9317 closed bug (fixed)

Tabs: Incorrect remote tab detection in IE7

Reported by: roeycohen@… Owned by: roeycohen@…
Priority: minor Milestone: 1.10.4
Component: ui.tabs Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

there is a problem with the TABs widget under IE7. adding a new tab using java-script and calling refresh doesn't work properly.

the problem is that "anchor.href" under ie7 does not return the full URL, only what is written inside the href attribute. this causes isLocal(line 26 at the source code) to fail and always return false even if i want a new local tab.

please let me know if you need more data, Roey

Change History (9)

comment:1 Changed 5 years ago by Scott González

Owner: set to roeycohen@…
Status: newpending

Can you please provide a reduced test case showing the problem? You can use http://jsfiddle.net/tj_vantoll/ZjgbK/ as a starting point.

comment:2 Changed 5 years ago by roeycohen@…

Status: pendingnew

ok, i've upload a working sample: http://jsfiddle.net/ZjgbK/20/

running chrome, ie >= 8 works fine.

switching to ie7 mode doesn't work (the 2nd alert does not contain the whole url, causing the widget's isLocal to think that the dynamically added tab is not local. also the new div container is always visible because the plugin doesn't even look for it.

help :) Roey

comment:3 Changed 5 years ago by roeycohen@…

please notice that this is not a duplicate of http://bugs.jqueryui.com/ticket/7822 (i'm not using the base tag).

though the solution may be giving us the programmers the option to tell the widget whether the tab is local or not.

thanks, Roey

comment:4 Changed 5 years ago by tj.vantoll

Resolution: notabug
Status: newclosed

You're running into this IE <= 7 quirk http://stackoverflow.com/questions/1593174/wrong-extraction-of-attrhref-in-ie7-vs-all-other-browsers.

Pass the href attribute embedded in the HTML string ($( "<a href='#dynamic'></a>") instead of $( "a", { href: "#dynamic" } ) and this will work fine: http://jsfiddle.net/tj_vantoll/PGfNT/

comment:5 Changed 5 years ago by Scott González

Resolution: notabug
Status: closedreopened

I wouldn't say that this isn't a bug. It might be a won't fix though.

comment:6 Changed 5 years ago by Scott González

Milestone: none1.11.0
Status: reopenedopen
Summary: ui tabs - isLocal function IE7 bugTabs: Incorrect remote tab detection in IE7

comment:7 Changed 5 years ago by Scott González

Resolution: fixed
Status: openclosed

Tabs: Restore anchor cloning for remote tab testing. Fixes #9317 - Tabs: Incorrect remote tab detection in IE7.

Changeset: daf3f0d9af5b29dc090e15d57cf884e3c12f7cad

comment:8 Changed 5 years ago by Scott González

Tabs: Restore anchor cloning for remote tab testing. Fixes #9317 - Tabs: Incorrect remote tab detection in IE7. (cherry picked from commit daf3f0d9af5b29dc090e15d57cf884e3c12f7cad)

Changeset: 39ff5b36e4ed2513f7dc11c22ea4df5d03f9f7b7

comment:9 Changed 5 years ago by Scott González

Milestone: 1.11.01.10.4
Note: See TracTickets for help on using tickets.