Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9352 closed bug (fixed)

Accordion: Active header has no focus indicator

Reported by: jzaefferer Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.accordion Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

When using the keyboard to navigate the accordion, there's no visual indicator when the activate header has keyboard focus. This is already obvious when moving focus to an accordion, where the first header is activate and receives the invisible focus.

Change History (6)

comment:1 Changed 4 years ago by tj.vantoll

  • Status changed from new to open

comment:2 Changed 4 years ago by jzaefferer

Is this a duplicate of #9428? That one is newer, but has more detail...

comment:3 Changed 4 years ago by tj.vantoll

No, #9428 is specifically related to the color of <a> elements.

This one is caused by .ui-accordion-header having .ui-helper-reset, which eliminates the outline. Seems like we should dump that class and manually apply the rules needed to .ui-accordion-header itself.

comment:4 Changed 4 years ago by tj.vantoll

This should do it: https://github.com/jquery/jquery-ui/pull/1034. font-size and margin seemed to be the only reason .ui-helper-reset was needed.

comment:5 Changed 4 years ago by TJ VanToll

  • Resolution set to fixed
  • Status changed from open to closed

Accordion: Avoid resetting outline on headers. Fixes #9352: Accordion - Active header has no focus indicator

Changeset: 9470af0bbefafa3d81c3709674a45a54b693e7cf

comment:6 Changed 4 years ago by tj.vantoll

  • Milestone changed from none to 1.11.0
Note: See TracTickets for help on using tickets.