Opened 6 years ago

Closed 6 years ago

#9372 closed bug (duplicate)

Autocomplete input fields in modal form do not display the .ui-menu

Reported by: tscholiadis Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

I was using jQuery 1.9.2 and had placed an input field with autocomplete on a Modal Dialog, and was populating it using Ajax and Json. It displayed the .ui-menu correctly.

After upgrading to jQuery 1.10.3 it stopped displaying the .ui-menu with no errors visible in the JavaScript console. After searching hi and low someone suggested I read through the changelogs (which admittedly I hadn't) and found a workaround to this problem.

In changelog 1.10.1, for Autocomplete you write:

Added: Use .ui-front instead of .zIndex() for the suggestions menu. (7d5fe02)

Following your link and looking through your code gave me an idea: I performed my Autocomplete search, and then I moved the dialog to the side! That's when I noticed the .ui-menu was behind the Modal Dialog.

I fixed this by adding the following CSS rule:

ul.ui-autocomplete.ui-menu {
  z-index: 1000;
}

Although I have a workaround, I'm posting this so that you can fix it in your next release.

Change History (1)

comment:1 Changed 6 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #9272.

Note: See TracTickets for help on using tickets.