Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#9381 closed bug (fixed)

Sortable: Connected list placeholders have an inaccurate initial position

Reported by: dylanpyle Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.sortable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hey folks,

I'm running into an issue with jQuery-UI 1.10.3 (+ jQuery 2.0.2) regarding the behavior of connected sortable lists.

Reduced test case at: http://jsfiddle.net/VNZW8/

Expected behavior: When dragging an element from the sidebar to the main content area, the initial placeholder and subsequent drop point is below the existing items if appropriate.

Observed behavior: The placeholder always initially appears at the top of the receiving list prior to any existing items, unless the mouse is moved to the top of the list then back down again.

I'm seeing this behavior in Chrome 27 and Firefox 21, and have no reason to suspect it's browser-dependent.

This issue is not present in UI 1.9.2 (+ jQuery 1.9.1), which implies it's a recent regression.

Happy to clarify if there's any additional questions.

Change History (5)

comment:1 Changed 4 years ago by dylanpyle

Update for clarification, here's what I'm seeing vs. what I'd expect to see:

http://f.cl.ly/items/3v1s3w1z1a1t0v0H4743/actual.png

http://f.cl.ly/items/2x2q1u2m0n3G2K330W2p/expected.png

Last edited 4 years ago by dylanpyle (previous) (diff)

comment:2 Changed 4 years ago by tj.vantoll

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9314.

comment:3 Changed 4 years ago by tj.vantoll

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from Connected list placeholders have an inaccurate initial position to Sortable: Connected list placeholders have an inaccurate initial position

Likely has the same root cause as #9314.

comment:4 Changed 3 years ago by Kris Borchers

  • Resolution set to fixed
  • Status changed from reopened to closed

Sortable: Adjust itemWithLeastDistance algorithm in _contactContainers to properly handle dragging items to the beginning and ends of lists. Fixes #9314 - Sortable: Items cannot be dragged directly into bottom position. Fixes #9381 - Sortable: Connected list placeholders have an inaccurate initial position

Changeset: 601ad962e0a417bb369378ed7704a0b493eac365

comment:5 Changed 3 years ago by scottgonzalez

  • Milestone changed from none to 1.11.0
Note: See TracTickets for help on using tickets.