Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#9407 closed bug (fixed)

Accordion: aria-expanded attribute on wrong element

Reported by: johumber Owned by:
Priority: minor Milestone: 1.10.4
Component: ui.accordion Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Steps to reproduce: 1) Open http://jqueryui.com/resources/demos/accordion/default.html in IE9+ with JAWS 12+. 2) This will display the collapsible accordion with Section1 open. 3) Navigate the accordion listening for expanded/collapsed information. 4) Open http://www.oaa-accessibility.org/examplep/accordian1/ in IE9+ with JAWS 12+ 5) Navigate the accordion listening for expanded/collapsed information. (Note: I am not for their use of image based "expanded/collapsed" graphics with alt attributes because the information is repeated. Please stick with the span based indicators.)

According to the WAI-ARIA 1.0 Authoring Practices (http://www.w3.org/TR/wai-aria-practices/#accordion), "An accordion should manage the expanded/collapsed state of each TAB by maintain its aria-expanded state."

The aria-expanded attribute should be on the HTML element where role="tab" not role="tabpanel"

This will supply the expanded/contracted information to all AT when navigating the accordion.

Change History (7)

comment:1 Changed 5 years ago by tj.vantoll

The documentation on the attribute does seem to indicate that it is intended to be applied to the headers and not the panels.

VoiceOver did not give me useful information regardless of where I placed the attributes, but that might just be my VoiceOver ignorance. I don't have access to JAWS at the moment but I should be able to take a look next week.

comment:2 Changed 5 years ago by johumber

I tested with NVDA 2013.1.1 and it does announce the expanded and collapsed information on the http://www.oaa-accessibility.org/examplep/accordian1/ example.

comment:3 Changed 5 years ago by tj.vantoll

Status: newopen
Summary: aria-expanded attribute on wrong element in AccordionAccordion: aria-expanded attribute on wrong element

Confirmed this on JAWS and VoiceOver.

comment:4 Changed 4 years ago by Monika Piotrowicz

Resolution: fixed
Status: openclosed

Accordion: moving aria-expanded from active tabpanel to active tab. Fixed #9407 - Accordion: aria-expanded attribute on wrong element

Changeset: f16d0c7e267794aa20411581b15870d9babd7930

comment:5 Changed 4 years ago by tj.vantoll

Milestone: none1.11.0

comment:6 Changed 4 years ago by Monika Piotrowicz

Accordion: moving aria-expanded from active tabpanel to active tab. Fixed #9407 - Accordion: aria-expanded attribute on wrong element (cherry picked from commit f16d0c7e267794aa20411581b15870d9babd7930)

Changeset: d21e8a6964d80a32cdb9773aa364141a2492dc5a

comment:7 Changed 4 years ago by Scott González

Milestone: 1.11.01.10.4
Note: See TracTickets for help on using tickets.