Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9540 closed bug (duplicate)

Resizable does not stop on 'west' side when mouse moves outside the containment

Reported by: PaulSinnema Owned by:
Priority: minor Milestone: none
Component: ui.resizable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

When the resizable is inside a containment and the containment is inside a div that has an absolute position then when reaching the left side of the containment the left and width of the resized object jump back to their original values.

Here's a JSFiddle showing the behavior: http://jsfiddle.net/PaulSinnema/9A7CJ/1/

I've trace it back to the _change() function that calculates the wrong left and width in the 'w:' function.

Change History (6)

comment:1 Changed 6 years ago by PaulSinnema

comment:2 Changed 6 years ago by PaulSinnema

Is anyone watching this?

comment:3 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7485.
Hi PaulSinnema,

Thanks for taking the time to contribute to the jQuery UI project. This is a duplicate of #7485 so I'm closing this as such. If you would like to offer your patch as a fix for the issue please send it as a pull request.

comment:4 Changed 6 years ago by PaulSinnema

Last edited 6 years ago by PaulSinnema (previous) (diff)

comment:5 in reply to:  3 ; Changed 6 years ago by PaulSinnema

Replying to tj.vantoll:

Duplicate of #7485.
Hi PaulSinnema,

Thanks for taking the time to contribute to the jQuery UI project. This is a duplicate of #7485 so I'm closing this as such. If you would like to offer your patch as a fix for the issue please send it as a pull request.

I'm trying to send you a pull request but I really don't understand how this should work. The GitHub let's me create a 'pull request' but the moment I click 'send pull request' the button is grayed for a moment and then returns without errors or warnings. In my history it still says there are 0 pull requests. What am I doing wrong?

comment:6 in reply to:  5 Changed 6 years ago by tj.vantoll

Replying to PaulSinnema:

Replying to tj.vantoll:

Duplicate of #7485.
Hi PaulSinnema,

Thanks for taking the time to contribute to the jQuery UI project. This is a duplicate of #7485 so I'm closing this as such. If you would like to offer your patch as a fix for the issue please send it as a pull request.

I'm trying to send you a pull request but I really don't understand how this should work. The GitHub let's me create a 'pull request' but the moment I click 'send pull request' the button is grayed for a moment and then returns without errors or warnings. In my history it still says there are 0 pull requests. What am I doing wrong?

I'm assuming you want to send https://github.com/PaulSinnema/jquery-ui/commit/32c1f148230b2f3223d6c3a86b878ba9b7520585 as a pull request? If so one problem I notice is that the commit is your fork's master branch. Take another look at http://contribute.jquery.org/commits-and-pull-requests/, specifically the "Never Commit On Master" section. When you push a new branch to your fork, GitHub should prompt you to create a pull request.

Note: See TracTickets for help on using tickets.