Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#9611 closed bug (fixed)

Resizable: can be moved when grid option is set

Reported by: bannmann Owned by: k_borchers
Priority: minor Milestone: 1.10.4
Component: ui.resizable Version: 1.10.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

When using resizable() without using draggable(), I would expect that it is impossible for the user to make the widget move.

However, when using the grid option, this is no longer the case. As my demo jsfiddle demonstrates, you can make the gadget move by dragging the west handle all the way to the right or the north handle down.

Note that this does not happen for every grid size (in the example, 50 is broken but 80 is fine), and never happens for the east or south handles.

My production system uses jqUI 1.10.3 with jQuery 2.0.3, the jsFiddle uses the same jqUI version with jQuery 1.9.1 because that was the version used on the jqueryui.com resizable() demo page.

Change History (6)

comment:1 Changed 4 years ago by tj.vantoll

Status: newopen
Summary: Resizable can be moved when grid option is setResizable: can be moved when grid option is set
Version: 1.10.31.10.0

Confirmed. This regressed in 1.10.0, likely due to this commit https://github.com/jquery/jquery-ui/commit/6e0a0553ce85997e4f37597800b440b1e4371b5b.

comment:2 Changed 4 years ago by Scott González

Keywords: regression added

comment:3 Changed 4 years ago by k_borchers

Owner: set to k_borchers
Status: openassigned

comment:4 Changed 4 years ago by Kris Borchers

Resolution: fixed
Status: assignedclosed

Resizable: Only resize/reposition if size is greater than specified grid

Fixes #9611 Closes gh-1132

Changeset: 20c1648f68660b267eec302d43a7b1014cda6e1a

comment:5 Changed 4 years ago by Kris Borchers

Resizable: Only resize/reposition if size is greater than specified grid

Fixes #9611 Closes gh-1132 (cherry picked from commit 20c1648f68660b267eec302d43a7b1014cda6e1a)

Changeset: 20b44cc9bf023bd711b80117b4f185a62301bf52

comment:6 Changed 4 years ago by Scott González

Milestone: none1.10.4
Note: See TracTickets for help on using tickets.