Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#9650 closed bug (fixed)

Menu: Disabled item visible through submenu on top

Reported by: jzaefferer Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.menu Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

In a menu with disabled items, submenus that end up on top of those disabled items, don't properly overlay the item - you can see the text of the disabled item through the submenu.

This can be addressed by setting a z-index on the submenu. Based on that it looks like having an element with opacity screws up the stacking order.

Testcase, confirmed in Chrome 30 and Firefox 24 on OSX 10.9: http://jsbin.com/AYUmUx/1/edit

This happens on any menu enough submenus or just a small window, where the flip collision will eventually position a menu over a parent menu.

Change History (4)

comment:1 Changed 3 years ago by jzaefferer

  • Status changed from new to open

This seems to only affect the first menu level (updated testcase), so adding our class ui-front to the submenus should help to address this.

comment:3 Changed 3 years ago by Jörn Zaefferer

  • Resolution set to fixed
  • Status changed from open to closed

Menu: Add ui-front on submenus to address opacity messing up stacking order. Fixes #9650 - Menu: Disabled item visible through submenu on top

Changeset: 4992fc902eae207737be33e5b937980b4765bbf7

comment:4 Changed 3 years ago by jzaefferer

  • Milestone changed from none to 1.11.0
Note: See TracTickets for help on using tickets.