Opened 6 years ago

Closed 6 years ago

#9653 closed bug (duplicate)

user agent :focus style breaks tab metaphor

Reported by: schrotie Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

At least in Firefox and Chromium clicking a tab gives it :focus and the user agent style creates an outline for this. Thus a freshly selected Tab has a line around it and implicitly - and most importantly - below it. This breaks the tab metaphor which only works flawlessly, when there is no separator between the active tab and the respective content area. This CSS snippet fixes the problem:

.ui-tabs-active.ui-state-focus, .ui-tabs-active.ui-state-focus * {outline: none 0;}

Change History (1)

comment:1 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #6146.
Duplicate of #6146. You can remove this yourself, although we recommend not.

Note: See TracTickets for help on using tickets.