Opened 6 years ago

Closed 6 years ago

#9655 closed bug (duplicate)

Droppable: Tolerance doesn't take draggable's axis into account

Reported by: joshgreifer Owned by: joshgreifer
Priority: minor Milestone: none
Component: ui.droppable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/apaul34208/Y6KM9/4/

When a draggable's axis is set, over() is triggered when the mouse pointer (not the draggable) is dragged over an accepting droppable regardless of the droppable's tolerance value, even though the draggable is not within the droppable's tolerance area - i.e. beahaves as though tolerance was set to 'pointer'. Tested in multiple browsers, recent versions of jQueryUI.

Posted in stackoverflow: http://stackoverflow.com/questions/19915668/constrained-draggable-should-not-trigger-over-in-droppable-in-this-situation

Change History (4)

comment:1 Changed 6 years ago by Scott González

Owner: set to joshgreifer
Status: newpending

I'm not seeing that behavior. In fact, I can't even get my pointer to the bottom droppable while the draggable exists since you're destroying the instance as soon as the pointer moves out of the draggable element.

Can you please provide an updated test case?

comment:2 in reply to:  1 Changed 6 years ago by joshgreifer

Status: pendingnew

Replying to scott.gonzalez:

I'm not seeing that behavior. In fact, I can't even get my pointer to the bottom droppable while the draggable exists since you're destroying the instance as soon as the pointer moves out of the draggable element.

Can you please provide an updated test case?

Sorry, posted incorrect jsFiddle. Updated. The linked one is an attempt at a workaround. jsFiddle to exhibit behavior is: http://jsfiddle.net/joshgreifer/Y6KM9/

Last edited 6 years ago by joshgreifer (previous) (diff)

comment:3 Changed 6 years ago by Scott González

Component: ui.draggableui.droppable
Status: newopen
Summary: droppable's over() fired when draggable not within its tolerance area if draggable's axis is setDroppable: Tolerance doesn't take draggable's axis into account

comment:4 Changed 6 years ago by Scott González

Resolution: duplicate
Status: openclosed

Duplicate of #4977.

Note: See TracTickets for help on using tickets.