Opened 5 years ago

Closed 5 years ago

#9685 closed bug (duplicate)

draggable goes out of containment, a few pixels in each drag

Reported by: fejesjoco Owned by:
Priority: minor Milestone: none
Component: ui.draggable Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Please look at this fiddle: http://jsfiddle.net/e2yfC/255/

Drag the thing to the bottom edge, it will stop there at first. But then stop dragging and start dragging down again, and it will go a few pixels down. And you can repeat it to make it go farther, and it also works for the right edge, but not the top and left. Whenever you start dragging down/right and the thing already touches the borders, you can go a few pixels farther away from the containment.

Resizable does not seem to be affected by a similar bug, so it does calculate the bounds correctly.

Tested in Firefox 25.0.1 and Chrome 31.

Change History (3)

comment:1 Changed 5 years ago by dekajp

this could be duplicate of 7016 - http://jsfiddle.net/tj_vantoll/Q4bkR/

comment:2 Changed 5 years ago by fejesjoco

I agree, it didn't come up as a duplicate while I was typing the title.

comment:3 Changed 5 years ago by tj.vantoll

Resolution: duplicate
Status: newclosed

Duplicate of #7016.
Thanks dekajp. fyi if you include a "#" trac will automatically build a link for you. #7016

Note: See TracTickets for help on using tickets.