Opened 6 years ago

Closed 3 years ago

#7016 closed bug (fixed)

Draggable: draggable can be pulled out of containment in Chrome and IE8

Reported by: Trainmaster Owned by: mikesherov
Priority: minor Milestone: 1.11.2
Component: ui.draggable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

First of all the Example: http://jsfiddle.net/QFVxC/12/

Follow these steps:

  1. Move the object to the bottom of the container
  2. Now, again select the object and try to move it out of the container downwards
  3. Repeat the previous step a few times. You will see, that you can slowly pull the object out of the container

FF 3.6.13 + Opera 11.01 works fine

Change History (15)

comment:1 Changed 6 years ago by raziel057

I also noticed this problem in Chrome 9 and IE8.

comment:2 Changed 5 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 5 years ago by mikesherov

Status: newopen
Summary: Draggable object pops out from container (Chrome + IE 8)Draggable: draggable can be pulled out of containment in Chrome and IE8

confirmed on latest: http://jsfiddle.net/cLVYr/1/ Also noticed that if you add padding to the container: http://jsfiddle.net/cLVYr/ , the problem goes away, so it must be a boundary condition issue.

comment:4 Changed 5 years ago by mikesherov

#8373 is a duplicate of this ticket.

comment:6 Changed 4 years ago by Scott González

#9218 is a duplicate of this ticket.

comment:7 Changed 4 years ago by BardMorgan

I tried adding padding to a div I was using for containment and the problem persisted. I added a border and the problem resolved. I edited the second fiddle above (http://jsfiddle.net/cLVYr/) and deleted the border and you can once again move the contained object slowly outside the container. The new fiddle is at http://jsfiddle.net/BardMorgan/PK5dY/.

comment:8 Changed 4 years ago by BardMorgan

Ok.. one more revision. If you use both a border and padding it resolves. If you use only one, the problem persists.

comment:9 Changed 4 years ago by tj.vantoll

#4489 is a duplicate of this ticket.

comment:10 Changed 4 years ago by tj.vantoll

Reduced the test case against master a bit: http://jsfiddle.net/tj_vantoll/Q4bkR/

comment:11 Changed 4 years ago by Aradesh

There is one more bug related to this. If draggable element has child div with position: absolute, and this element is outside of draggable container - containment is not work on bottom and right borders. http://jsfiddle.net/9Wu5T/

comment:12 in reply to:  11 Changed 4 years ago by tj.vantoll

Replying to Aradesh:

There is one more bug related to this. If draggable element has child div with position: absolute, and this element is outside of draggable container - containment is not work on bottom and right borders. http://jsfiddle.net/9Wu5T/

I'm not seeing any issues with that test case. Are you only seeing the behavior in certain browsers?

comment:13 in reply to:  8 Changed 4 years ago by vesoljc

Replying to BardMorgan:

Ok.. one more revision. If you use both a border and padding it resolves. If you use only one, the problem persists.

And you have to use 3px (or more) padding. At least on Chrome 30.0.1599.69...

comment:14 Changed 4 years ago by tj.vantoll

#9685 is a duplicate of this ticket.

comment:15 Changed 3 years ago by mikesherov

Milestone: 2.0.01.11.2
Owner: set to mikesherov
Status: openassigned

I know what's doing this. PR coming soon.

comment:15 Changed 3 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Draggable: Ensure overflow:visible containments are correctly measured

Fixes #7016

Changeset: 48ea2aadad11938cc5ddbd9a340c4ca1c997550d

Note: See TracTickets for help on using tickets.