Opened 8 years ago

Closed 8 years ago

#9742 closed bug (wontfix)

[Combobox][IE10+] autocomplete listing cannot be opened with large data

Reported by: xlefebvre Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.3
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

Context: I encountered a problem using jQuery combobox (http://jqueryui.com/autocomplete/#combobox) with large data (3000+ items) and IE10.

Problem: When I'm trying to click on button to open the autocomplete list, browser is busy some moment (which is normal, there is a lot of append(), but at the end, focus is on the textbox and autocomplete is opened briefly, but does not remain opened.

It only happens with IE10+, IE9 is working as well as chrome.

Example: http://jsfiddle.net/e7CX5/ , it's not the last version of jQuery on this exemple, but I've encountered this bug also with last version (jQuery 1.10.2 and jQuery UI 1.10.3) Code is exactly the same as jQuery website, I've only provided a large select.

The probleme seems to be caused by blur() event on input set by jQuery autocomplete, but I did not understand why it's working when there is less data.

Thanks in advance for you help !

Change History (1)

comment:1 Changed 8 years ago by Scott González

Resolution: wontfix
Status: newclosed

That demo isn't designed to work with thousands of elements in the select. You should build your own implementation based on the demo as a reference.

Note: See TracTickets for help on using tickets.