Opened 5 years ago

Closed 5 years ago

#9787 closed bug (wontfix)

Tabs: Not Working in iframes in IE7

Reported by: rbmanian75 Owned by:
Priority: minor Milestone: none
Component: ui.tabs Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Please visit the page http://jqueryui.com/tabs/ in IE7 or IE7 Compatibility mode in >IE7 and you can see that the tab content does not change when switching the tabs. It seems to be that all the 3 tab contents are rendered together.

Change History (8)

comment:1 Changed 5 years ago by Scott González

Resolution: worksforme
Status: newclosed

Actually, the tabs work just fine in IE7. See http://jqueryui.com/resources/demos/tabs/default.html

Although our code projects support old browsers like IE7, our web sites do not.

comment:2 Changed 5 years ago by rbmanian75

We were not having this behavior with jquery ui 1.10.3 after upgrading to 1.10.4 we are having this behavior. When we just test with sample page you have provided it works. But with our application it behaved the same as the web site http://jqueryui.com/tabs/.

Some changes made in the jQuery 1.10.4 breaks our application. We are not able to reproduce it with simple tab html. It happens in the context of our application.

We roll backed to 1.10.3 and everything works fine.

comment:3 Changed 5 years ago by rbmanian75

And one more thing if i name the tabs like ui-tabs-1, ui-tabs-2 it works fine in 1.10.4

comment:4 in reply to:  2 Changed 5 years ago by tj.vantoll

Replying to rbmanian75:

We were not having this behavior with jquery ui 1.10.3 after upgrading to 1.10.4 we are having this behavior. When we just test with sample page you have provided it works. But with our application it behaved the same as the web site http://jqueryui.com/tabs/.

Some changes made in the jQuery 1.10.4 breaks our application. We are not able to reproduce it with simple tab html. It happens in the context of our application.

We roll backed to 1.10.3 and everything works fine.

We need a reduced test case in order to look into this. The only thing related to this that changed was #9317, so you might to look through that ticket.

comment:5 Changed 5 years ago by rbmanian75

Now i can reproduce the problem.

Please try this in a html file

<html>
<body>
<iframe src="http://jqueryui.com/resources/demos/tabs/default.html" width="100%" height="100%"></iframe>
</body>
<html>

it seems to be that it is fixed in http://bugs.jqueryui.com/ticket/8653 but now it is reintroduced in jQuery UI 1.10.4

you are right the change made in 9317 causes this If i remove the line

anchor = anchor.cloneNode(false);

it works fine.

comment:6 Changed 5 years ago by tj.vantoll

Resolution: worksforme
Status: closedreopened
Summary: jQuery UI 1.10.4 Tab not working in IE7Tabs: Not Working in iframes in IE7

comment:7 Changed 5 years ago by rockenreno

I also experienced this problem using frames in IE11 (IE7 compatibility mode enabled).

The fix of removing

anchor = anchor.cloneNode(false);

appears to work for me.

comment:8 Changed 5 years ago by Scott González

Resolution: wontfix
Status: reopenedclosed

We're no longer landing bug fixes for IE7 and will fully drop support soon.

Note: See TracTickets for help on using tickets.