Opened 5 years ago

Closed 2 years ago

#9796 closed bug (wontfix)

Autocomplete: Search triggered on initialization if input contains an umlaute

Reported by: Mil Owned by:
Priority: minor Milestone: none
Component: ui.autocomplete Version: 1.10.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi

I have a very odd issue with autocomplete, IE10 and jquery-ui version 1.10.4 (also occures in version 1.9.0).

If I add a value with umlaut (ö, ä, ü) as initial value in the input with autocomplete, autocomplete gets triggered while loading the document.

Please look here http://jsfiddle.net/MilKAOS/NRGxw/1/ and play run.

I could only see that behaviour in IE10 (10.0.9200.16466), older versions and compatibility mode seem to be fine. Maybe there is a localization option I miss?

Thanks in advance Mil

Change History (8)

comment:1 Changed 5 years ago by Scott González

Status: newopen
Summary: Autocomplete with umlaute in valueAutocomplete: Search triggered on initialization if input contains an umlaute

I'm not sure if we'll be able to do anything about this. IE is triggering an input event.

comment:2 Changed 5 years ago by Scott González

I've reported this to Microsoft to see if they have any suggestions to work around this. Here's a reduced test case without jQuery: http://dev-test.nemikor.com/bugs/ie/input-event-on-load.html

comment:3 in reply to:  2 Changed 5 years ago by Mil

I did too. Shortly after you stated that this is a browser issue. Last message was, that they will look into it. https://connect.microsoft.com/IE/feedback/details/816915/ie10-triggers-input-event-on-initialization-if-input-contains-an-umlaut

comment:4 Changed 4 years ago by nicoder5

Hi,

I was faced the same bug and found a workaround here that seems to work :

http://stackoverflow.com/questions/22349375/jquery-ui-autocomplete-automatically-fire-ie

 		input: function( event ) {
-				if ( suppressInput ) {
+				if ( suppressInput || typeof suppressInput === 'undefined' ) {
 				suppressInput = false;
 				event.preventDefault();
 				return;
 			}
 			this._searchTimeout( event );
 		},

Has this been proposed / discussed already ? Is it a good idea ?

thanks, nico

comment:5 Changed 3 years ago by Scott González

#14924 is a duplicate of this ticket.

comment:6 Changed 3 years ago by Scott González

#14925 is a duplicate of this ticket.

comment:7 Changed 3 years ago by Mil

Hi all

Good news everyone. Microsoft took my bug yesterday from Connect to their platform for IE Edge issues/feature requests and set the status for the bug to Fixed.

See here: https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/109149/

Mil

comment:8 Changed 2 years ago by Scott González

Resolution: wontfix
Status: openclosed

This doesn't seem to affect Edge and we don't have a fix for IE, so I'm going to close.

Note: See TracTickets for help on using tickets.