Ticket #7390 (closed bug: fixed)

Opened 3 years ago

Last modified 18 months ago

Resizable: https domain reports 'unsecured items' in IE7

Reported by: mattramey Owned by:
Priority: minor Milestone: 1.8.14
Component: ui.resizable Version: 1.8.12
Keywords: Cc:
Blocking: Blocked by:

Description

A simple jqueryui dialog (using jQuery UI 1.8.12) with resizable enabled causes the IE dialog to pop up "This page contains both secure and unsecure items" on https domains.

The offending code is in the css for select: .ui-resizable-handle

Tickets #7233, and #7293 both attempted to address this problem, but in using either fix, results in this issue. The original "about:blank" does not produce this issue in IE7 and rids the console error that is reported in Chrome dev tools.

Change History

comment:1 Changed 3 years ago by scott.gonzalez

  • Component changed from ui.core to ui.resizable
  • Summary changed from jQueryUI Dialog control causes an https domain to report 'unsecured items' in IE7 to Resizable: https domain reports 'unsecured items' in IE7

comment:2 Changed 3 years ago by mattramey

Thanks for moving the ticket Scott -- I was kicking myself after I realized I couldn't change it after.

comment:3 Changed 3 years ago by Scott González

  • Status changed from new to closed
  • Resolution set to fixed

Resizable: Remove workaround for handles not working in IE when transparent with overlapping content. Fixes #7397 - Resizable: icon not showing. Fixes #7390 - Resizable: https domain reports 'unsecured items' in IE7. Reopens #7233 - Resizable: resizable handles fail to work in IE if transparent and content overlaps.

Changeset: 42dd56de5a0d67a7db2c2f49dc665e62afce8dda

comment:4 Changed 3 years ago by Scott González

Resizable: Remove workaround for handles not working in IE when transparent with overlapping content. Fixes #7397 - Resizable: icon not showing. Fixes #7390 - Resizable: https domain reports 'unsecured items' in IE7. Reopens #7233 - Resizable: resizable handles fail to work in IE if transparent and content overlaps. (cherry picked from commit 42dd56de5a0d67a7db2c2f49dc665e62afce8dda)

Changeset: 9c0cd477848aa3782b36b8af95b073e11285e653

comment:5 Changed 3 years ago by scott.gonzalez

  • Milestone changed from 1.9 to 1.8.14

comment:6 Changed 3 years ago by rdworth

#7673 is a duplicate of this ticket.

comment:7 Changed 18 months ago by scott.gonzalez

#8818 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.