Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10140 closed bug (fixed)

Resizable: Width calculation is wrong when containment element is "position: relative"

Reported by: kamatamadai Owned by: mikesherov
Priority: minor Milestone: 1.11.1
Component: ui.resizable Version: 1.11.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

Width is protrude from containment element.

See this example: http://jsfiddle.net/kamatamadai/5Tucc/

The previous version(v1.10.4) is working properly.

I think that it is this change cause https://github.com/jquery/jquery-ui/commit/c03cb8079c6984fb9286a64d980d367d86b9cd8b .

It should be added the following test case.

$( "#child" ).resizable({

containment: "#parent", handles: "all"

});

Change History (8)

comment:1 Changed 3 years ago by Scott González

Status: newopen

fiddle with proper inclusion of jQuery UI: http://jsfiddle.net/5Tucc/5/

comment:2 Changed 3 years ago by tj.vantoll

Keywords: regression added

Reduced this some http://jsfiddle.net/tj_vantoll/5Tucc/6/.

I also verified this is a regression because the test case works with 1.10.4.

comment:4 Changed 3 years ago by mikesherov

Owner: set to mikesherov
Status: openassigned

comment:5 Changed 3 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Resizable: Fix containment calculation with relative parent

Remove an incorrect fix introduced in 47cd5b6f that causes width calculations to be incorrect once the correct fix was introduced in c03cb807

Fixes #10140

Changeset: 2779212a0e6e34fdea3f0d442e4d92218ac943fa

comment:6 Changed 3 years ago by Scott González

Milestone: none1.11.1

comment:7 Changed 3 years ago by Jyoti Deka

Resizable: Fix containment width with relative parent.

Refs #10140 Closes gh-1303

Changeset: 750a8fd0c267aaba784f6dc76924619dbb459762

comment:8 Changed 3 years ago by tj.vantoll

#10438 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.