Opened 5 years ago

Closed 5 years ago

#10438 closed bug (duplicate)

Resizable: containment on resizable not in the top-left corner

Reported by: Akatsukle Owned by:
Priority: minor Milestone: none
Component: ui.resizable Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

Here is the fiddle : http://jsfiddle.net/34zVD/5/

The containment option doesn't work as expected when the resizable elem is not initially located in the top left corner. In the fiddle, you can see that you can't resize the fiddle toward the top or the left. You can also resize outside the div, but in the limit of the distance to the top-left corner of the container. Here in the example, you cannot got to the right more than 100px and to the bottom for more than 150px.

I've encountered this bug with 1.11.0 and 1.10.4. I haven't tried the previous versions.

Change History (5)

comment:1 Changed 5 years ago by Akatsukle

Component should be ui.resizable instead of ui.core. Sorry, I haven't found how to edit.

comment:2 Changed 5 years ago by tj.vantoll

Component: ui.coreui.resizable
Status: newopen
Summary: containment on resizable not in the top-left cornerResizable: containment option fails when element is not the parent

The core issue is that the containment option doesn't work unless the element is an immediate parent: http://jsfiddle.net/tj_vantoll/mb3Hh/. I would've swore there was a duplicate for this but I can't find one anywhere.

comment:3 Changed 5 years ago by Scott González

The ticket you're looking for is #7485, but that fix is included in 1.11.0.

comment:4 Changed 5 years ago by Akatsukle

Well, it's still not working even with 1.11.0. I've modified the second jsfiddle (http://jsfiddle.net/tj_vantoll/mb3Hh/) to include the latest version of jquery ui (https://code.jquery.com/ui/1.11.0/jquery-ui.min.js), and it's still not working.

I don't completely understand why my fiddle is acting like this then. According to yours, my resizable shouldn't be able to get resized, as its parents is only 50px² wide.

comment:5 Changed 5 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed
Summary: Resizable: containment option fails when element is not the parentResizable: containment on resizable not in the top-left corner

Duplicate of #10140.
The fix for #10140 resolved this (see http://jsfiddle.net/34zVD/6/), so I'm going to switch this back to the original title and mark this as a duplicate.

Note: See TracTickets for help on using tickets.