Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10437 closed bug (fixed)

Resizable: border with grid option working wrong

Reported by: Akatsukle Owned by: mikesherov
Priority: minor Milestone: 1.11.1
Component: ui.resizable Version: 1.11.0
Keywords: regression Cc:
Blocked by: Blocking:

Description

Here's the jsfiddle: http://jsfiddle.net/34zVD/4/

If you are trying to resize an element which has a border (extra large here to make the bug obvious) to the minimal size, it will work well with most handle. However, with the top handle, the left handle and the top-left handle, the minimum size will be twice the larger of the border+the size it should have took.

For example, in this fiddle, the minimal size will be 70px (50px+2*10px) instead of 50px.

I have encountered this bug with 1.10.4 and 1.11.0. I haven't tried the other versions.

Change History (5)

comment:1 Changed 3 years ago by tj.vantoll

Keywords: regression added
Status: newopen
Summary: resizable on element with border with grid option working wrongResizable: border with grid option working wrong

Confirmed. This looks to have regressed in 1.10.4 as this same example works fine in 1.10.3 (http://jsfiddle.net/34zVD/8/). The most likely cause is the fix for #9611.

comment:2 Changed 3 years ago by mikesherov

Owner: set to mikesherov
Status: openassigned

This is indeed caused by #9611. Looking into it.

comment:4 Changed 3 years ago by Mike Sherov

Resolution: fixed
Status: assignedclosed

Resizable: account for padding & border in grids.

Fixes #10437

Changeset: 7c8790dcc881c8e82390bb5abe31fad35afdaaa0

comment:5 Changed 3 years ago by mikesherov

Milestone: none1.11.1
Note: See TracTickets for help on using tickets.