Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#10543 closed bug (fixed)

Dialog: Selectmenu/autocomplete in dialog window is cut off

Reported by: aldra Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.dialog Version: 1.11.0
Keywords: Cc:
Blocked by: Blocking:

Description

When a selectmenu widget is placed in a dialog window and there is not enough space to show all the options, it's cut off. The option list should appear on top of the dialog.

Test this jsFiddle: http://jsfiddle.net/bcuonqt0/

Change History (10)

comment:1 Changed 3 years ago by tj.vantoll

  • Resolution set to notabug
  • Status changed from new to closed

You need to either use the appendTo option (http://jsfiddle.net/tj_vantoll/eab24oqm/) or change the CSS overflow on the dialog elements (http://jsfiddle.net/tj_vantoll/cuc3un92/).

comment:2 Changed 3 years ago by scottgonzalez

  • Resolution notabug deleted
  • Status changed from closed to reopened

Both of those solutions will introduce other issues though. Using appendTo should never be necessary for default behavior when .ui-front is in play. Changing overflow will just reintroduce #9521. I think we need to find a different solution for #9521.

comment:3 Changed 3 years ago by aldra

The appendTo solution brings another bug. If you close the option list and reopen it, the list is now behind the dialog window (Firefox 31.0).

But the second solution with the CSS overflow works for me. I'll use this method until it's fixed.

Thanks for your quick response!

comment:4 Changed 3 years ago by tj.vantoll

#10553 is a duplicate of this ticket.

comment:5 Changed 3 years ago by tj.vantoll

#10565 is a duplicate of this ticket.

comment:6 Changed 2 years ago by Gruewo

The same problem happens with ui.autocomplete. Using appendTo with autocomplete also only works for the first dialog invocation.

appendTo can't reliably solve the problem. The other proposed solution brings back #9521 and forces us to modify the ui.dialog styles to make jQuery UI widgets usable inside a ui.dialog.

should this be considered a bug of ui.core or ui.css-framework?

comment:7 Changed 2 years ago by tj.vantoll

  • Component changed from ui.selectmenu to ui.dialog
  • Summary changed from Selectmenu in dialog window is cut off to Dialog: Selectmenu/autocomplete in dialog window is cut off

I'm moving the component to dialog and changing the title as this affects multiple widgets.

comment:8 Changed 2 years ago by tj.vantoll

#10621 is a duplicate of this ticket.

comment:9 Changed 2 years ago by TJ VanToll

  • Resolution set to fixed
  • Status changed from reopened to closed

Dialog: Remove overflow: hidden and reposition resize handles

Fixes #10543 Closes gh-1439

Changeset: 912eb62ccb77059148a1fe14bdb57b7f9e44a14c

comment:10 Changed 2 years ago by tj.vantoll

  • Milestone changed from none to 1.12.0
Note: See TracTickets for help on using tickets.