Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10602 closed bug (fixed)

Tooltip: stays open by using click and TAB on inputs

Reported by: julien.pacchiarotti Owned by:
Priority: blocker Milestone: 1.11.2
Component: ui.tooltip Version: 1.11.1
Keywords: regression Cc:
Blocked by: Blocking:

Description

Hi, I have just found an issue which I describe here => http://jsfiddle.net/L4k1byb8/

I have tested the same behavior in jquery ui 1.10.4 => http://jsfiddle.net/jwbx4a2g/ and it was working.

I have investigated a bit in the source code and my conclusion is this part of code could be the problem:

        close: function( event ) {
---
                this.closing = true;
                this._trigger( "close", event, { tooltip: tooltip } );

                //if you remove this if, it works
                if ( !this.hiding ) {
                        this.closing = false;
                }
        },

        _tooltip: function( element ) {
---

Change History (8)

comment:1 Changed 3 years ago by julien.pacchiarotti

Erratum: there is the correct jsfiddle with 1.10.4 => http://jsfiddle.net/jwbx4a2g/3/

I wanted to add that this seems to happen only when the tooltip is used with delegated items, otherwise it works => http://jsfiddle.net/2u7wvLp2/

comment:2 Changed 3 years ago by tj.vantoll

Keywords: regression added
Status: newopen
Summary: Tooltip stays open by using click and TAB on inputsTooltip: stays open by using click and TAB on inputs

This regressed in 1.11.1 because it worked fine in 1.11.0. There's only one related commit so it's almost certainly caused by https://github.com/jquery/jquery-ui/commit/32bef7ad4ea120fb32a79e1ea49bd9b846bcf835.

comment:3 Changed 3 years ago by julien.pacchiarotti

Thanks for the correction, it works well ! If I am correct, this will be part of the next release of JQuery UI ?

comment:4 in reply to:  3 Changed 3 years ago by tj.vantoll

Replying to julien.pacchiarotti:

Thanks for the correction, it works well ! If I am correct, this will be part of the next release of JQuery UI ?

We don't know yet. We'll update this ticket when we do.

comment:5 Changed 3 years ago by Scott González

Milestone: none1.11.2
Priority: minorblocker

comment:7 Changed 3 years ago by Scott González

Resolution: fixed
Status: openclosed

Tooltip: Properly track hiding and closing for delegated tooltips

Fixes #10602 Closes gh-1353

Changeset: 8825d93dc877d182cf4a3fce37b6c2593cf08552

comment:8 Changed 3 years ago by Scott González

#10659 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.