Opened 2 years ago

Closed 16 months ago

Last modified 8 months ago

#10726 closed bug (fixed)

Button: selecting text causes an inconsistent state

Reported by: Patrick1701 Owned by:
Priority: minor Milestone: 1.12.0
Component: ui.button Version: 1.11.2
Keywords: regression Cc:
Blocked by: Blocking:

Description

It is possible to get a "selected" radio-choice button ui element, without really having a selected value.

See http://jsfiddle.net/gdsawfkm/4/

It seems to me, onChange events are triggered by mouse-events, not by input-element changed events, or something...

kind regards Patrick

Change History (8)

comment:1 Changed 2 years ago by tj.vantoll

  • Keywords regression added
  • Status changed from new to open
  • Summary changed from Button RadioChoices / slipping from element or selecting text doesnt really select, but looks like to Button: selecting text causes an inconsistent state

This regressed in 1.10.4 as this works fine in 1.10.3: http://jsfiddle.net/0f0ohfs1/. The fix for #7665 broke this so this ticket is possibly a duplicate of #9990.

comment:2 Changed 2 years ago by Patrick1701

... this ticket is possibly a duplicate of #9990.

Unfortunately, I'm not able to reproduce it with jsfiddle mentioned there, but it really sounds like its the same issue.

comment:3 Changed 2 years ago by Patrick1701

I would appreciate to change the priority to major, and also create a fix for 1.10.5?

best regards Patrick

comment:4 Changed 2 years ago by Patrick1701

Hi all, this issue is really a problem.

We often have users on our system reporting unexpected behaviors from the UI which shows selected radio choices, which are not submitted via form to the server, becoming persistent. Later on users find "old" data, having in mind they changed it, and submitted/saved it, but its not.

This issue is quite critical!

Please, please, provide a fix for 1.11.3!

kind regards Patrick

comment:5 Changed 2 years ago by mfazekas

We also hit this issue, and it's pretty bed as user sees he selected something but in reality the selection hasn't made or on another one. I can reproduce on the mentioned jsbin with 10.4 and later. A workaround we use is demonstrated in http://jsfiddle.net/kakwryLe/6/ (commented line)

comment:6 Changed 2 years ago by arschmitz

The button widget is re-written for 1.12, and the checkbox / radio functionality has been factored out into a separate widget. I just checked on the new widget and this problem does not exist there.

comment:7 Changed 16 months ago by scottgonzalez

  • Milestone changed from none to 1.12.0
  • Resolution set to fixed
  • Status changed from open to closed

Confirmed fixed in master.

comment:8 Changed 8 months ago by scottgonzalez

#14987 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.