Opened 10 years ago

Closed 7 years ago

Last modified 7 years ago

#4603 closed bug (fixed)

Resizable: alsoResize option doesn't work with containment

Reported by: GoZ Owned by:
Priority: minor Milestone: 1.10.0
Component: ui.resizable Version: 1.7.2
Keywords: alsoResize, containment Cc:
Blocked by: Blocking:

Description

I have an image in a div. The div is resizable and has properties alsoResize:image and containment:'parent'.

When i resize the div and reach the containment limit, the image continue resizing.

Issue: Put $.ui.plugin.add("resizable", "alsoResize" ...) plugin after $.ui.plugin.add("resizable", "containment" ...) plugin and it works great.

Attachments (1)

resizable_ticket_4603.html (1.5 KB) - added by sc0rchin 10 years ago.
html visual test of ticket #4603

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by GoZ

I forgot a propertie. I use aspectRatio to. So it's why i don't want the image be resized when i reach the containment limit.

comment:2 Changed 10 years ago by Jörn Zaefferer

Milestone: TBD1.8

Changed 10 years ago by sc0rchin

Attachment: resizable_ticket_4603.html added

html visual test of ticket #4603

comment:3 Changed 10 years ago by sc0rchin

I can confirm that by moving;

$.ui.plugin.add("resizable", "alsoResize" ...)

to end of the script file after;

$.ui.plugin.add("resizable", "containment" ...)

this bug is fixed.

comment:4 in reply to:  description Changed 10 years ago by watanabe

I think this bug caused #5559., and like #4624.

"adding 'containment' first" may be better than "moving 'alsoResize' to end of the 'containment'". (other plugins in 'resizable' should respect 'containment'.)

comment:5 Changed 10 years ago by watanabe

'grid' may be the 'second' plugin.

comment:6 Changed 9 years ago by Scott González

#7393 is a duplicate of this ticket.

comment:7 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:8 Changed 7 years ago by tj.vantoll

Status: newopen
Summary: AlsoResize doesn't work fine with containmentResizable: alsoResize option doesn't work with containment

Verified this is still an issue in 1.9.1 - http://jsfiddle.net/tj_vantoll/rGJ7g/.

comment:9 Changed 7 years ago by Scott González

Resolution: fixed
Status: openclosed

Resizable: Respect containment for alsoResize option. Fixes #4603 - Resizable: alsoResize option doesn't work with containment. Fixes #5559 - Dialog: Content grows bigger than widget on resize at document edge.

Changeset: 5ba267e7c78f0bc257383c822d241c5369e8e49d

comment:10 Changed 7 years ago by Scott González

Milestone: 2.0.01.10.0
Note: See TracTickets for help on using tickets.