Opened 9 years ago

Closed 7 years ago

#5215 closed enhancement (fixed)

Effects color: Add support for rgba animations

Reported by: ericw Owned by: Corey Frang
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.5
Keywords: color Cc:
Blocked by: Blocking:

Description

rgba-values in color css attributes allow firefox 3 and safari 3 to have transparent colors. it would be great to be able to animate them with jquery using the jquery.color plugin.

Change History (10)

comment:1 Changed 9 years ago by rdworth

Summary: Support for rgba animations in jquery.colorEffects color: Support for rgba animations in jquery.color

comment:2 Changed 9 years ago by rdworth

Summary: Effects color: Support for rgba animations in jquery.colorEffects color: Add support for rgba animations

comment:3 Changed 9 years ago by kapouer

It is also a problem with e.g. chromium, since :

> $(document.body).css('backgroundColor')
"rgba(0, 0, 0, 0)"

So one cannot save backgroundColor value to animate back and forth, since rgba is not understood by color plugin.

comment:4 Changed 9 years ago by piouPiouM

See my commit on GitHub for a support of the rgba animations and its demonstration.

comment:5 Changed 9 years ago by aidan

The patch looks good, why isn't this getting more attention!

comment:6 Changed 9 years ago by Scott González

#4736 is a duplicate of this ticket.

comment:7 Changed 8 years ago by Corey Frang

Status: newopen

comment:8 Changed 8 years ago by Corey Frang

Milestone: 1.next1.9
Owner: set to Corey Frang
Status: openassigned

comment:9 Changed 8 years ago by Corey Frang

Keywords: color added

comment:10 Changed 7 years ago by Scott González

Resolution: fixed
Status: assignedclosed

Upgrade to jquery-color 2.0pre. Fixes #6910 - Trying to animate the background color of a document fragment can easily fail. Fixes #5215 - Effects color: Add support for rgba animations. Fixes #4372 - Animate backgroundColor to 'transparent'. Fixes #5393 - getColor reports inaccurate color for transparent elements in Webkit. Fixes #3806 - Feature request: expose getRGB and getColor.

Changeset: 13d560b8f05a8eedbf28851824fe639a254f9fd0

Note: See TracTickets for help on using tickets.