Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#5510 closed bug (fixed)

'ui.tabs' shows multiple tabs when clicking rapidly

Reported by: pulpulpullie Owned by:
Priority: minor Milestone: 1.8.5
Component: ui.tabs Version: 1.8
Keywords: tabs fx animate Cc:
Blocked by: Blocking:

Description

If a user clicks on a second tab before the animation of the first tab is done, the content of both tabs will be shown.

I've attached a file to demonstrate this issue.

Attachments (1)

tabsBug.html (1.1 KB) - added by pulpulpullie 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by pulpulpullie

Attachment: tabsBug.html added

comment:1 Changed 10 years ago by dtaylor

I can second that this occurs. This is how I create my tabs (nothing special), but clicking through them quickly will jumble the content (multiple pages show on one tab).

$('#tabContainer').tabs({
	ajaxOptions: {cache: false},
	cache: true,
	select: function(event, ui) {
		... omitted ...
	},
	selected: index,
		
	load: function(event, ui) {
		... omitted ...
	}
});

comment:2 Changed 9 years ago by Scott González

Milestone: TBD1.8.5
Resolution: fixed
Status: newclosed

This was fixed in 1.8.5.

comment:3 Changed 9 years ago by Scott González

#5680 is a duplicate of this ticket.

comment:4 Changed 9 years ago by Scott González

#4854 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.