Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#5637 closed bug (fixed)

Dialog: Dimensions of reused overlay may cause scrollbars

Reported by: mkemmerling Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.1
Keywords: dialog overlay Cc:
Blocked by: Blocking:

Description

The dialog overlay reuses old instances to work around an IE memory leak with alpha transparency. This might result in a too large overlay if the window is rescaled in between successive uses of the dialog.

To reproduce the bug open the modal form demo in a wide browser window and

  1. Open the 'Create new user' dialog and cancel it.
  2. Make the browser window smaller.
  3. Reopen the dialog.

The window has now a horizontal scroll bar due to a too wide overlay.

Workaround: Set the overlay's width and height to 0, either before destroying it or before setting its dimensions on creation.

Change History (4)

comment:1 Changed 8 years ago by k_borchers

I have sent a pull request at https://github.com/jquery/jquery-ui/pull/211.

Thanks

comment:2 Changed 8 years ago by Scott González

Status: newopen
Summary: Dimensions of reused dialog overlayDialog: Dimensions of reused overlay may cause scrollbars

comment:3 Changed 8 years ago by Scott González

Resolution: fixed
Status: openclosed

Dialog: Reduce old overlay dimensions to 0x0 to avoid sizing issues. Fixes #5637 - Dialog: Dimensions of reused overlay may cause scrollbars.

Changeset: a0f16a00b9398f123dbb5e027b21b04af13fcc1b

comment:4 Changed 8 years ago by Scott González

#7562 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.