Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#6671 closed bug (fixed)

Datepicker: setDate manipulates its argument

Reported by: mbarkhau Owned by:
Priority: minor Milestone: 1.8.7
Component: ui.datepicker Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

setDate should make a clone of its argument and not reset the time.

See: http://jsbin.com/oromi4/4

Change History (5)

comment:1 Changed 6 years ago by pheiberg

Committed proposed fix in GitHub.

comment:2 Changed 6 years ago by pheiberg

  • Resolution set to fixed
  • Status changed from new to closed

Datepicker: changed setDate not to modify the passed date argument. Fixes #6671 - setDate manipulates its argument

Changeset: d69f2ecb1273f382d83b13c349a8c76b17bee2a6

comment:3 Changed 6 years ago by scottgonzalez

  • Summary changed from setDate manipulates its argument to Datepicker: setDate manipulates its argument

comment:4 Changed 6 years ago by scottgonzalez

#6143 is a duplicate of this ticket.

comment:5 Changed 5 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.7
Note: See TracTickets for help on using tickets.