Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6715 closed bug (fixed)

Hide and Show try to affect hidden and showing elements

Reported by: etiger13 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.core Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery UI show and hide methods:

Hide tries to hide elements that are already hidden and briefly shows them on screen before hiding them. It should ignore these elements if they are already hidden.

Same with show, but you know, opposite

Test case for problem: http://jsfiddle.net/eTiger13/zCNHZ/

Change History (6)

comment:2 Changed 8 years ago by Scott González

Component: ui.coreeffects.core
Status: newopen

comment:3 Changed 8 years ago by Corey Frang

I'm not sure what happened to your fix, but its a dead link, can you maybe reconstruct it in the form of a pull request?

If not, I'm sure I can fix this one...

comment:4 Changed 8 years ago by k_borchers

I have submitted a new fix here https://github.com/jquery/jquery-ui/pull/240.

Thanks

comment:5 Changed 8 years ago by Corey Frang

Resolution: fixed
Status: openclosed

Effects.core: Check Visibility vs 'hide' and 'show' modes, finish immediately if neccessary - Fixes #6715 - Hide and Show try to affect hidden and showing elements

Changeset: d18cd7ed0f41213aca9f29ae67c360ca6b21abfa

comment:6 Changed 7 years ago by Scott González

#7816 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.