Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#6801 closed bug (duplicate)

Dialog: overlay loses opacity on long pages

Reported by: aslamr Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description

We are using jquery (version 1.8.4) to show pop up on click of a link. it works fine for the page with height less than 65536px.

But when page height exceeds 65536 px then background of page becomes gray This is observed only in IE browser.

please let us know solution.

Change History (12)

comment:1 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed
Summary: Jquery popup background grayed out for very lengthy pages (for height more than 65536px)Dialog: Jquery popup background grayed out for very lengthy pages (for height more than 65536px)

I'm not seeing this behavior. Please provide a reduced test case showing the problem.

comment:2 Changed 9 years ago by aslamr

I attached a sample HTML file with the CSS using jsFiddle. Please use this link: http://jsfiddle.net/KTXdg/ to open it and follow these steps.

In the html file, there are two types of overlays, one is the overlay that is created using regular, old CSS. When the link to show that CSS overlay is clicked, the overlay that's shown is semi-transparent like it's supposed to be. However, when the link to create the jQueryUI modal dialog is clicked, the background overlay is completely opaque. This only occurs after the size of the document is a certain size (65536). To test this, with the 'main' div, when the height is at 65520, this issue is occurring. As soon as that's moved down to 65519, then the issue is not there

comment:3 Changed 9 years ago by Scott González

#7102 is a duplicate of this ticket.

comment:4 Changed 9 years ago by Scott González

Resolution: worksforme
Status: closedreopened

comment:5 Changed 9 years ago by Scott González

Summary: Dialog: Jquery popup background grayed out for very lengthy pages (for height more than 65536px)Dialog: overlay loses opacity on long pages

comment:6 Changed 8 years ago by kahunacohen

Is there any progress on this? If not, I have encountered this and would be willing to work on it.

comment:7 in reply to:  6 Changed 8 years ago by rdworth

Any progress would have been posted here. Have at it.

comment:8 Changed 8 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

comment:9 Changed 8 years ago by Scott González

Duplicate of #4995.

comment:10 Changed 8 years ago by Felix Nagel

Confirm this issue with latest stable jQuery UI on Win Vista and IE8 (latest). Interesting fact is that Ive tried 5 different PCs (all with Vista and latest IE8) and the error occurred only on 3 of it.

Possible (quick and dirty) solution is a semi transparent PNG instead of opacity.

comment:11 Changed 8 years ago by Felix Nagel

Sorry, I was not aware this bug is closed.

Solution could be found in this commit: https://github.com/jquery/jquery-ui/commit/c9e187cd9d3cecdb39ecfb0ab0389614973a40c3

comment:12 Changed 8 years ago by jasonday

For reporting purposes, we also have this issue.

Note: See TracTickets for help on using tickets.