Opened 10 years ago

Closed 7 years ago

#4995 closed bug (fixed)

Dialog: Modal Dialog's overlay dissapears in IE when content is tall.

Reported by: Xar Owned by:
Priority: major Milestone: 1.10.0
Component: ui.dialog Version: 1.7.2
Keywords: overlay Cc:
Blocked by: Blocking:

Description

Hi, First of all, thank you for your great, great library :)

I'm writting an app that uses the UI Dialog plugin. I've found that when I open a modal Dialog under IE7 and the content is tall (as in its height), the modal shadow covers only a fraction of the page and its opacity is set to 100%. This makes the Dialog not modal at all.

I've tried this under Vista & Windows 7. Attached you can find a test case I wrote and a screencapture of this bug in action.

Thank you very much for your help, and greetings from Spain

Attachments (1)

IE7 Modal error.zip (34.0 KB) - added by Xar 10 years ago.
Sample and screen capture

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by Xar

Attachment: IE7 Modal error.zip added

Sample and screen capture

comment:1 Changed 10 years ago by Jörn Zaefferer

Priority: blockermajor

comment:2 Changed 10 years ago by rdworth

Milestone: TBD1.8

comment:3 Changed 9 years ago by Scott González

Summary: Modal Dialog's shadow dissapears in IE when content is tallModal Dialog's overlay dissapears in IE when content is tall

comment:4 in reply to:  description Changed 9 years ago by catapricop

Replying to Xar:

Hi, First of all, thank you for your great, great library :)

I'm writting an app that uses the UI Dialog plugin. I've found that when I open a modal Dialog under IE7 and the content is tall (as in its height), the modal shadow covers only a fraction of the page and its opacity is set to 100%. This makes the Dialog not modal at all.

I've tried this under Vista & Windows 7. Attached you can find a test case I wrote and a screencapture of this bug in action.

Thank you very much for your help, and greetings from Spain

Hi Xar! Did you find any solution to your problem? I may have encountered the same problem . What I have is a large document that necessitates scroll to display its content; When I open a modal dialog the overlay is gray opaque, it covers only a part of the document and it's not modal at all. Please let me know if you found out how to deal with this. Best regards!

comment:5 Changed 9 years ago by Scott González

Resolution: fixed
Status: newclosed

Merge pull request #263 from kborchers/bug_4995

Dialog: Create modal overlay after dialog is shown and check scrollHeight and offsetHeight in all IE versions. Fixed #4995 - Modal Dialog's overlay dissapears in IE when content is tall

Changeset: c9e187cd9d3cecdb39ecfb0ab0389614973a40c3

comment:6 Changed 8 years ago by Scott González

#6801 is a duplicate of this ticket.

comment:7 Changed 7 years ago by Scott González

Resolution: fixed
Status: closedreopened

The dialog still disappears in IE8: http://jsfiddle.net/ErAyw/

comment:8 Changed 7 years ago by Scott González

Milestone: 1.9.01.10.0

comment:9 Changed 7 years ago by Scott González

Keywords: overlay added
Status: reopenedopen

comment:10 Changed 7 years ago by Jörn Zaefferer

Summary: Modal Dialog's overlay dissapears in IE when content is tallDialog: Modal Dialog's overlay dissapears in IE when content is tall.

comment:11 Changed 7 years ago by Nate Eagle

Resolution: fixed
Status: openclosed

Dialog: Awesome new stacking and overlay implementation. Fixes the following tickets:

Fixes #3534 - Dialog: Modal dialog disables all input elements on page. Fixes #4671 - Dialog: Modal Dialog disables vertical scroll bar in Chrome & Safari. Fixes #4995 - Dialog: Modal Dialog's overlay dissapears in IE when content is tall. Fixes #5388 - Dialog: Don't change z-index when already at the top. Fixes #5466 - Dialog: "modal" Dialog Incorrectly Cancels Input Events. Fixes #5762 - Dialog: Get rid of z-index workaround, document it instead. Fixes #6267 - Dialog: checkboxes that inherit a z-index < jqueryui.dialog z-index don't work. Fixes #7051 - Dialog: modal prevents tab key from moving focus off slider handle. Fixes #7107 - Dialog: Modal dialog event loss with high zindex child elements (FF 3.6). Fixes #7120 - Dialog: Modal operation interrupts drag drop marker functionality on gmaps. Fixes #8172 - Dialog: Change event cancelled when opening modal dialog from another modal dialog. Fixes #8583 - Dialog: Mouse event wrongly stopped. Fixes #8722 - Dialog: Remove stack option. Fixes #8729 - Dialog: Remove zIndex option.

Changeset: 3829a37ca122e923c3a08b964c4b1a946a2a1456

Note: See TracTickets for help on using tickets.