Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6812 closed bug (fixed)

Position: Collision detection fails on the right side in Internet Explorer

Reported by: danlash Owned by:
Priority: blocker Milestone: 1.8.8
Component: ui.position Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery 1.4.4 jQuery UI 1.8.7

If you try to position an element that will be off-screen, collision detection in Internet Explorer does not work. Other browsers will correctly flip the element, but IE places the element in the original position.

It appears to work correctly in jQuery UI 1.8.5 (the latest on jsFiddle). I created the test case in jsBin:

http://jsbin.com/iwelo4

Change History (5)

comment:1 Changed 6 years ago by scottgonzalez

  • Status changed from new to open
  • Summary changed from Collision detection not working in Internet Explorer to Position: Collision detection fails on the right side in Internet Explorer
  • Version changed from 1.8.7 to 1.8.5

Using the default demo on view.jqueryui.com, 1.8.5 is the first version in which this is broken. The default demo is actually a better test case than the linked jsbin.

comment:2 Changed 6 years ago by scottgonzalez

  • Priority changed from minor to blocker

comment:3 Changed 6 years ago by scottgonzalez

#6831 is a duplicate of this ticket.

comment:4 Changed 6 years ago by Scott González

  • Resolution set to fixed
  • Status changed from open to closed

Position: Fixed calculation of collision dimensions. Fixes #6812 - Position: Collision detection fails on the right side in Internet Explorer.

Changeset: c1cc00f6096ddab9d27214c7f62279127a37d8dd

comment:5 Changed 6 years ago by scottgonzalez

  • Milestone changed from 1.9 to 1.8.8
Note: See TracTickets for help on using tickets.