Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#6840 closed feature (fixed)

Accordion: Rename changestart event to beforeActivate

Reported by: Scott González Owned by:
Priority: blocker Milestone: 1.9.0
Component: ui.accordion Version: 1.8.7
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Jörn Zaefferer)

Deprecate changestart in 1.9 and remove in 2.0. Update UI properties: Change newContent to newPanel, oldContent to oldPanel.

Change History (6)

comment:1 Changed 8 years ago by Scott González

Priority: minorblocker
Status: newopen

comment:2 Changed 8 years ago by Scott González

#5910 is a duplicate of this ticket.

comment:3 Changed 8 years ago by Scott González

Summary: Accordion: Rename changestart event to beforeactivate and allow cancelingAccordion: Rename changestart event to beforeActivate

comment:4 Changed 8 years ago by Scott González

Resolution: fixed
Status: openclosed

Accordion: Renamed changestart and change events to beforeActivate and activate, respectively. Fixes #6840 - Accordion: Rename changestart event to beforeActivate. Fixes #6842 - Accordion: Rename change event to activate.

Changeset: 088ef05142168de75d2afcbe447a5b44cb2d3673

comment:5 Changed 7 years ago by Jörn Zaefferer

Description: modified (diff)

comment:6 Changed 7 years ago by Jörn Zaefferer

Accordion: Update activate and beforeActivate event properties to newPanel/oldPanel (instead of content). Fixes #6840 and #6842

Changeset: e0fe788ee0c0c0d8d23f9d90b9acff713ba1302f

Note: See TracTickets for help on using tickets.