Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#6922 closed bug (wontfix)

Interactions with cloned helpers are broken with jQuery 1.5

Reported by: rebugger Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.sortable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Using jQuery 1.5, sortable() removes previous applied .button() if it is used with helper: 'clone'. After dropping the sorted item its original source (without the applied .button()) is inserted at the new position. Using jQuery 1.4.4, everything works fine.

Here is an example: http://jsfiddle.net/rebugger/hKthm/5/

Change History (7)

comment:1 Changed 11 years ago by Scott González

Status: newopen

This is caused by an undocumented breaking change in .clone().

comment:2 Changed 11 years ago by Scott González

Ticket filed against jQuery core: http://bugs.jquery.com/ticket/8123

comment:3 Changed 11 years ago by Scott González

#6924 is a duplicate of this ticket.

comment:4 Changed 11 years ago by Scott González

Summary: Sortable with helper=clone bug using jQuery 1.5Interactions with cloned helpers are broken with jQuery 1.5

Turning this into a general ticket so we can close all related tickets as duplicates. We're just going to wait for 1.5.1 to be released.

comment:5 Changed 11 years ago by Scott González

Resolution: wontfix
Status: openclosed

comment:6 Changed 10 years ago by Scott González

#6955 is a duplicate of this ticket.

comment:7 Changed 10 years ago by Scott González

#6956 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.