Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7008 closed bug (fixed)

Chromium-Browser does not support html-entities in datePicker i18n-translation

Reported by: MrMaxx Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Some Translations for the datePicker contain html-entities. These work perfecly fine in Firefox, but not in Chromium.

Examples: Spanish Translation: dayNames: ['Domingo','Lunes','Martes','Miércoles','Jueves','Viernes','Sábado'], á has to be changed with the corresponding Unicode Entity á

Italian Translation: dayNames: ['Domenica','Luned&#236','Marted&#236','Mercoled&#236','Gioved&#236','Venerd&#236','Sabato'], &#236 is not complete...change with ì

There are several occurances all over the Translation-Files. What i have found so far are occuances in languages : es, fi, it, no, pt, ro, sv and tr

Change History (4)

comment:1 Changed 9 years ago by MrMaxx

Chromium Version: 9.0.597.94 (73967) Ubuntu 10.04 Operation System: Ubuntu 10.04

comment:2 Changed 9 years ago by Scott González

#7007 is a duplicate of this ticket.

comment:3 Changed 9 years ago by Richard Worth

Resolution: fixed
Status: newclosed

Datepicker i18n: Changed all html named character entities to unicode hex entities. Fixed #7008 - Chromium-Browser does not support html-entities in datePicker i18n-translation

Changeset: 7c4d6a763dfb5f9debf30c9a20875e046e89bc76

comment:4 Changed 9 years ago by rdworth

For reference, in case anyone wants to review my work on 7c4d6a7:

http://www.whatwg.org/specs/web-apps/current-work/multipage/named-character-references.html

<		<
<		<
>		>
>		>

 		 
«		«

»		»

Á	Á
Í	Í

Þ		Þ

á	á
ä		ä
æ		æ
ç	ç
é	é
ì	ì
ì		ì
í	í

ð		ð
ó	ó
ö		ö
ú	ú
Note: See TracTickets for help on using tickets.